Back
Degraded

Processing performance has been affected.
Started 23 Sep at 06:35pm UTC, resolved 23 Sep at 07:54pm UTC.
API
Resolved
All services are currently back to normal. We have identified the root cause being related to network latencies in AWS. We are continuing to work with AWS to better understand the problem and mitigation strategies going forward.
Posted 23 Sep at 07:54pm UTC.

Created
We are experiencing a general degradation in processing time since 16:08:00 UTC. We're reviewing the root cause of the incident.
Posted 23 Sep at 06:35pm UTC.