Resolved
All services are currently back to normal.
The root cause of this issue is related to underlying latencies in AWS and is a recurrence of an earlier issue that we believed we had resolved.
While this issue is currently not in effect, we are continuing to work with AWS to identify and remediate the root issue to prevent its recurrence.
Posted .
Created
We are experiencing a general degradation in processing time since 13:37:00 UTC. We're reviewing the root cause of the incident.
Posted .