
Processing performance has been affected.
Started 3 Oct at 03:06pm UTC, resolved 3 Oct at 05:19pm UTC.
Resolved
All services are currently back to normal.
The root cause of this issue is related to underlying, intermittent network latencies in AWS and is a recurrence of an earlier issue that we are currently still investigating with AWS.
While investigations continue, we have restructured our infrastructure workloads such that fewer customers are impacted during these network latencies.
We truly value your ongoing trust and appreciate your patience and understanding as we continue to work on this issue.
Updated
All services have been operating at improved levels for the last 50 mins, however we do still observe somewhat higher than normal processing times for some customers. We are continuing to work on this issue.

Created
We are currently experiencing degradation in processing time, which may impact a subset of clients. Start time: 13:15:00 UTC.
Our team is actively working to resolve the issue and restore optimal performance. We’re reviewing the root cause of the incident. Thank you for your patience and understanding .