Status
Get in touch
Back
Resolved
Email collector is out of service
Started 5 May at 01:55pm UTC.
Affected services
API
Created
Email collector is back online
Posted 5 May at 01:55pm UTC.