Get in touch
Back
Degraded

Elevated errors during document processing

Started , resolved .

API
Resolved

We have implemented and validated a fix for the problematic edge case. All systems are back to normal.

Posted .
Updated

We have identified the root cause as being a newly surfaced edge case scenario in requests being submitted for processing. These particular requests consume an unusually high level of compute resources, which has downstream impact on other requests processed by the same worker processes.

We are currently working on a solution to handle these edge cases gracefully.

Posted .
Updated

We have reduced error rates further by over provisioning compute resources and spreading requests across more worker nodes. We are continuing work on identifying the root cause of the issue.

Posted .
Created

We are experiencing an increased error rate in document processing requests. A small percentage of requests are returning a 504 error response. We are investigating the issue.

Posted .