
Temporary Sign-In and Profile Switching Issues
Started 10 Sep at 02:00pm UTC, resolved 10 Sep at 09:32pm UTC.
Resolved
We are happy to announce that the remaining issues with profile switching functionality across accounts have been fully resolved. All affected features, including sign-in via Multi-Factor Authentication (MFA), connected third-party apps (e.g., Google), and profile switching, are now operating normally.
Admin users and standard email/password sign-ins were unaffected throughout.
No further workarounds are necessary. Our engineering team has implemented the fix and is monitoring the system closely to ensure stability.
We apologize for the inconvenience caused and appreciate your patience during this time.
Updated
We are pleased to report that the sign-in issues affecting non-admin users with Multi-Factor Authentication (MFA) and connected third-party apps (e.g., Google) have been resolved. Users should now be able to sign in normally using these methods.
However, we are still experiencing issues with profile switching functionality across accounts. Our engineering team is actively working to resolve this as quickly as possible. We expect a fix soon.

Created
Status: Investigating
Affected Services: User Authentication (Sign-In) and Profile Switching
We are currently experiencing temporary issues with the sign-in process on the Veryfi platform caused by the recent security rollout. This is primarily impacting:
Non-admin users attempting to sign in via Multi-Factor Authentication (MFA).
Users signing in through connected third-party apps like Google.
Profile switching functionality across accounts.
Admin users using standard email/password sign-in are generally unaffected.
Our engineering team is actively investigating and working to resolve these issues as quickly as possible. We expect a fix within the next few hours and will provide updates here.
Workaround: In the meantime, we encourage affected users to sign in using their email and password directly.
We apologize for the inconvenience and thank you for your patience while we address this.